-------productspurchasesupportnewsaboutliststipslinks-

Troi Plug-ins for FileMaker Pro 14 FileMaker Pro 14 Compatibility

(Page updated: August 7th, 2015)

Below you'll find some information regarding compatibility of Troi Plug-ins with FileMaker Pro 14. We will update this page when we release new versions of our plug-ins. Please check back for updates.
(The web page with information regarding compatibility of our plug-ins with FileMaker 13 is still available here.)

Summary

Running plug-ins with FileMaker Pro 14

FileMaker Pro (Advanced) 14, FileMaker Server (Advanced) 14 and WebDirect are 64-bit processes, for which plug-ins need to be compiled for 64-bit. See below for an overview of all Troi plug-ins and their compatibility with FileMaker Pro 14. If we release new compatible versions of our plug-ins we will provide information here, so please check back for updates.

64-bit plug-ins are needed for FileMaker Pro 14

With FileMaker Pro 14 you can only use plug-ins that are compiled for 64-bit. On Windows 64-bit plug-ins have a different extension: fmx64. In the download of a 64-bit compatible plug-in you will find this extra copy of the plug-in. Plug-ins for OS X can be universal and the extension is always the same: fmplugin. A universal plug-in is a single plug-in that will run on a 32-bit process as well as on 64-bit process. You can not easily see if an OS X plug-in is 64-bit compatible. We have created a simple dropper app called "Troi Architecture Check" to determine for which architectures a plug-in is compiled. You can download the app here.

Note: it is possible to run FileMaker Pro 14 legacy in 32-bit mode. For this you need to open the FileMaker Pro app in 32-bit mode on Mac OS X (see 'Get Info' of the FileMaker app). On Windows you need to install the (separate) 32-bit FileMaker Pro application. You can use this to run older plug-ins that are not compiled yet for 64-bit. Older plug-ins may not be fully compatible with FileMaker 14 though.

The same plug-in architecture

The plug-in architecture has not changed in FileMaker 14. So there is no need to change any function calls when converting to FileMaker 14 (as compared to the change in plug-in architecture introduced in FileMaker Pro 7).

Simple plug-in updating

Plug-in updating has been simplified in FileMaker Pro 12 and later. You now store plug-ins in solution files and install updates from container fields. The Auto Update plug-in is no longer needed. All new versions of Troi plug-ins provide an example file to demonstrate this update process in FileMaker Pro 12 and later.

Location of installed plug-ins

When you make use of the new plug-in updating functionality the plug-ins will be installed in the same location as with auto-updated plug-ins from FileMaker Server 9 through 11:

  • Windows Vista, Windows 7 and 8:
    C:\Users\User Name\AppData\Local\FileMaker\Extensions
  • OS X:
    Macintosh HD:Users:User Name:Library:Application Support:FileMaker:Extensions

TIP If you use auto-update ànd install plug-ins manually: it is best to only install plug-ins in the folders above and no longer use the Extensions folder next to the FileMaker Pro application itself.

Overview of Troi Plug-ins for FileMaker Pro 14

Here is an overview of all our plug-ins that are native and have been tested to work with FileMaker Pro 14 (and also FileMaker Pro 13 and 12).

   
Works native in
FileMaker 14, 13 and 12
  date of first version*
Mac OS X
Windows
remarks
Activator Plug-in May 12th, 2015
3.6
3.6
FMP14 version released!
Troi Dialog Plug-in May 12th, 2015
6.1
6.1
FMP14 version released!
Troi Encryptor Plug-in June 5th, 2015
3.0
3.0
FMP14 version released!
Troi File Plug-in May 12th, 2015
8.0
8.0
FMP14 version released!
Troi Serial Plug-in May 12th, 2015
4.0
4.0
FMP14 version released!
Troi Text Plug-in August 7th, 2015
3.5
3.5
FMP14 version released!
Troi URL Plug-in May 12th, 2015
4.1
4.1
FMP14 version released!

* This is the first version that was tested with FileMaker Pro 14

The following plug-in has not been compiled for 64-bit yet:

   
latest version
  date of version
Mac OS X
Windows
remarks
Troi Grabber Plug-in April 19th, 2012
2.3
2.3
runs with FMP 14 in 32-bit mode

Other older FileMaker Pro compatibility pages

The web pages with information regarding compatibility of all our plug-ins with other FileMaker versions are still available:


© 2015 Troi Automatisering, all rights reserved.